using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"is1t.*Test(\d+).*";
string input = @"""213Das ""is1t"" 'ein' Test32"" ""253Das ""ist"" 'ein' Test332"" ""23Das ""ist"" 'ein' Test342"" ""237Das ""is1t"" 'ein' Test32"" ""283Das ""ist"" 'ein' Test312"" ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}