package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+ )?\(?([0-9]{3})\)?[-. ]?([0-9]{3})[-. ]?([0-9]{4})$`)
var str = `1 456 789 4444`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}