using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<!\\)((?:\\{2})*)\""([^\""\\]*(?:\\.[^\""\\]*)*)\""";
string substitution = @"$1";
string input = @"[""\n"",""\t"",""'"",""\"",""\\"",""\\\""]
// \""
var s = ""d\""d\\\""f"";";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}