use strict;
my $str = '["\\n","\\t","\'","\\"","\\\\","\\\\\\""]
// \\"
var s = "d\\"d\\\\\\"f";';
my $regex = qr/(?s)(?<!\\)((?:\\{2})*)\"([^\"\\]*(?:\\.[^\"\\]*)*)\"/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";