import Foundation
let pattern = #"(?s)(?<!\\)((?:\\{2})*)\"([^\"\\]*(?:\\.[^\"\\]*)*)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
["\n","\t","'","\"","\\","\\\""]
// \"
var s = "d\"d\\\"f";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)