using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]\s*(?:[+-][+-]|\*/)\s*[0-9]";
string input = @"This is test 1 -- 1
This is test 2
This is test 3 + 1
This is test 4 */ 4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}