import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]\\s*(?:[+-][+-]|\\*/)\\s*[0-9]";
final String string = "This is test 1 -- 1\n"
+ "This is test 2\n"
+ "This is test 3 + 1\n"
+ "This is test 4 */ 4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}