const regex = new RegExp('[0-9]\\s*(?:[+-][+-]|\\*/)\\s*[0-9]', 'gm')
const str = `This is test 1 -- 1
This is test 2
This is test 3 + 1
This is test 4 */ 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}