# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*\d+(?:\.\d+)?$//gm;t' <<< "2.34 567 67.89
Text 2. More text 4.555. And 45"