package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*\d+(?:\.\d+)?$`)
var str = `2.34 567 67.89
Text 2. More text 4.555. And 45`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}