use strict;
my $str = '2.34 567 67.89
Text 2. More text 4.555. And 45';
my $regex = qr/\s*\d+(?:\.\d+)?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";