// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\d+(?:\.\d+)?$").unwrap();
let string = "2.34 567 67.89
Text 2. More text 4.555. And 45";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}