re = /^(?=( ?\d){5} *$)\d* ?\d*/m
str = '73648
3 0324
98734
98234
324234
324 343
33 345
f7364ffff8f '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end