using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ \t]*see also(?:[ \t]*:)?+[ \t]+(.*)";
string input = @"See Also: something.m, something_else.m
See Also: something.m, something_else.m
See Also : something.m, something_else.m
see also: something.m, something_else.m
see also : something.m, something_else.m
see also something.m, something_else.m
text before makes this invalid See Also: something.m, something_else.m
See Also :something.m, something_else.m
See Als: something.m, something_else.m";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}