const regex = /^[ \t]*see also(?:[ \t]*:)?+[ \t]+(.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ \\t]*see also(?:[ \\t]*:)?+[ \\t]+(.*)', 'gmi')
const str = `See Also: something.m, something_else.m
See Also: something.m, something_else.m
See Also : something.m, something_else.m
see also: something.m, something_else.m
see also : something.m, something_else.m
see also something.m, something_else.m
text before makes this invalid See Also: something.m, something_else.m
See Also :something.m, something_else.m
See Als: something.m, something_else.m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}