using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<(a|img)(?:\s[^>]*)*>)((?:(?!<\1).)*)";
string input = @"
<img>content</img> <img src=""some-pic-url"">content</img>
<a> content </a> <a href=""url"">content</a>
<a href=""url"">content</img>
<img src=""some-pic-url"">content</a>
<a href=""url"">content
<img src=""some-pic-url"">content";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}