import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<(a|img)(?:\\s[^>]*)*>)((?:(?!<\\1).)*)";
final String string = "\n"
+ "<img>content</img> <img src=\"some-pic-url\">content</img>\n"
+ "<a> content </a> <a href=\"url\">content</a>\n\n"
+ "<a href=\"url\">content</img>\n"
+ "<img src=\"some-pic-url\">content</a>\n"
+ "<a href=\"url\">content\n"
+ "<img src=\"some-pic-url\">content";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}