#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)[a-z\d]"
Local $sString = "լոռեմ իպսում դոլոռ սիթ ամեթ, նե եամ դոլոռեմ ածծոմմոդառե, վիմ ինանի պեռֆեծթո ռաթիոնիբուս ծու, պոսսե վիռիս ոպոռթեռե եխ վել. նե սուաս նոսթռուդ պեռ, ութռոքուե սալութանդի դեֆինիթիոնես ծում եթ, բլանդիթ ռեպռեհենդունթ նեծ ադ. նոսթեռ պռոբաթուս ութ վել, եա ալթեռա աեթեռնո աթոմոռում եում, նոմինավի թածիմաթես դելիծաթա ծու ուսու. սթեթ թոլլիթ "Hi There" 12345679"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")