const regex = /[\p{L}\d]/giu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{L}\\d]', 'giu')
const str = `լոռեմ իպսում դոլոռ սիթ ամեթ, նե եամ դոլոռեմ ածծոմմոդառե, վիմ ինանի պեռֆեծթո ռաթիոնիբուս ծու, պոսսե վիռիս ոպոռթեռե եխ վել. նե սուաս նոսթռուդ պեռ, ութռոքուե սալութանդի դեֆինիթիոնես ծում եթ, բլանդիթ ռեպռեհենդունթ նեծ ադ. նոսթեռ պռոբաթուս ութ վել, եա ալթեռա աեթեռնո աթոմոռում եում, նոմինավի թածիմաթես դելիծաթա ծու ուսու. սթեթ թոլլիթ "Hi There" 12345679`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}