$re = '/<p[^>]+>(.*?)<\/p>/m';
$str = '<p class=\'myClass1\' id="myId1" style="font-weight: bold">some text <span>here</span></p>
<p class=\'myClass2\' id="myId2" style="font-weight: bold">some more text <span>here</span></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);