using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^B*((AB*){2})*B*$";
string input = @"AABBABA
BABBAB
BABBBA
BABAAB
AABBABABA
A
AAA
ABABABABA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}