re = /^B*((AB*){2})*B*$/m
str = 'AABBABA
BABBAB
BABBBA
BABAAB
AABBABABA
A
AAA
ABABABABA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end