# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(@Column *\( *name *= *\"(.+?)\".+)"
test_str = (" @Column(name = \"UTL_DA_PRTCPZN_IC\", table = \"ALL_PRQZN_SEZ_PRNCPL\")\n"
" private Importo utiliDaPartecipazioneIC;\n\n"
" @Column(name = \"UTL_DA_PRTCPZN_IFD\", table = \"ALL_PRQZN_SEZ_PRNCPL\")\n"
" private Importo utiliDaPartecipazioneIFD;\n\n"
" @Column(name = \"PRQZN_RDZN_PRTCPZN_UTL_ALQ_IC\", table = \"ALL_PRQZN_SEZ_PRNCPL\")\n"
" private Aliquota riduzionePartecipazioniAliquotaIC;")
subst = "$1\\n\\t@BeanStructProperty(uniqueName = \"$2\")"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.