import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(<a href=\"#\">))([\\s\\S]| |w\\[0-9]| )+?(?=(<\\/a>))";
final String string = "<ul><li><a href=\"#\">test1</a></li><li><a href=\"#\">test2</a></li><a href=\"#\">test3</a></li></ul>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}