re = /(?<=(<a href="#">))([\s\S]| |w\[0-9]| )+?(?=(<\/a>))/
str = '<ul><li><a href="#">test1</a></li><li><a href="#">test2</a></li><a href="#">test3</a></li></ul>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end