const regex = new RegExp('^(?:([\\w]*)(?: (.*))? )?([\\w]+)$', 'gm')
const str = `Thinh
Nguyen Thinh
Nguyen Ngoc Thinh
Nguyen A B C Thinh`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);