$re = '`^(?:([\w]*)(?: (.*))? )?([\w]+)$`m';
$str = 'Thinh
Nguyen Thinh
Nguyen Ngoc Thinh
Nguyen A B C Thinh';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;