import re
regex = re.compile(r"^(?:([\w]*)(?: (.*))? )?([\w]+)$", flags=re.MULTILINE)
test_str = ("Thinh\n"
"Nguyen Thinh\n"
"Nguyen Ngoc Thinh\n"
"Nguyen A B C Thinh")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)