package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ServerConfig="(.*)\b(name=[^\s]+)\b(.*)"|"(.*)\b(name=[^\s]+)?"`)
var str = `ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=webserver"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver type=done"
ServerConfig="name=dataserver type=done"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}