use strict;
my $str = 'ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=webserver"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver type=done"
ServerConfig="name=dataserver type=done"
';
my $regex = qr/ServerConfig="(.*)\b(name=[^\s]+)\b(.*)"|"(.*)\b(name=[^\s]+)?"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}