re = /ServerConfig="(.*)\b(name=[^\s]+)\b(.*)"|"(.*)\b(name=[^\s]+)?"/m
str = 'ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=webserver"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver type=done"
ServerConfig="name=dataserver type=done"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end