package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`;(?<VCX_NODE>\w{3,4}#\d)\s*\w\s\d\s\d\s\w{3}\s-\s(?<mfctrunk>.*)\/(?<mfcline>.*)\((?<mfclineslot>\d{1,3})\)`)
var str = `VCX_Stat;30.09.2018 22:58:37;S;LNZ#1 V 1 0 LNZ - VIE___2MBit__/lnzvie1201(8):656825->663625 Voc `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}