const regex = /;(?<VCX_NODE>\w{3,4}#\d)\s*\w\s\d\s\d\s\w{3}\s-\s(?<mfctrunk>.*)\/(?<mfcline>.*)\((?<mfclineslot>\d{1,3})\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(';(?<VCX_NODE>\\w{3,4}#\\d)\\s*\\w\\s\\d\\s\\d\\s\\w{3}\\s-\\s(?<mfctrunk>.*)\\\/(?<mfcline>.*)\\((?<mfclineslot>\\d{1,3})\\)', 'g')
const str = `VCX_Stat;30.09.2018 22:58:37;S;LNZ#1 V 1 0 LNZ - VIE___2MBit__/lnzvie1201(8):656825->663625 Voc `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}