// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r";(?<VCX_NODE>\w{3,4}#\d)\s*\w\s\d\s\d\s\w{3}\s-\s(?<mfctrunk>.*)\/(?<mfcline>.*)\((?<mfclineslot>\d{1,3})\)").unwrap();
let string = "VCX_Stat;30.09.2018 22:58:37;S;LNZ#1 V 1 0 LNZ - VIE___2MBit__/lnzvie1201(8):656825->663625 Voc ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}