Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?i)^(?!.*(?:_dev|_pre|_prod|_test|_)$)[\w-]{1,64}$
/
gm
Input 1
1
New
!min0db_dev1 min0db_dev_dev min0db_ _dev _ min0db_dev1 min0db min0_devdb