import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?!.*(?:_dev|_pre|_prod|_test|_)$)[\\w-]{1,64}$";
final String string = "!min0db_dev1\n"
+ "min0db_dev_dev\n"
+ "min0db_\n"
+ "_dev\n"
+ "_\n"
+ "min0db_dev1\n"
+ "min0db\n"
+ "min0_devdb\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}