$re = '/^(?:N|S|E|W|NW|NE|SW|SE)$/m';
$str = 'N
S
E
W
NW
NE
SW
SE
SED
NEW';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);