#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(\w* \w*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})"
Local $sString = "Hans Wurst_12345678_NOZ1234567_24.04.2018"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)