import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w* \\w*)_(\\d{8})_(NOZ\\d{7})_(\\d{2}.\\d{2}.\\d{4})";
final String string = "Hans Wurst_12345678_NOZ1234567_24.04.2018";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}