package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[^a][^b]$`)
var str = `jd8a
8$fb
q(c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}