// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.\w+$").unwrap();
let string = "KM1208_sta1_cast3.csv
KM1208_sta1_cast6a.csv
KM1208_sta1_cast6b.csv
KM1208_sta2_cast7.csv
KM1208_sta2_cast6.csv
HS1301_sta1_cast2.csv
HS1301_sta2_cast5.csv
HS1301_sta3_cast8.csv
HS1301_sta3_cast9.csv";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}