$re = '/\bNOT\h+index=("?)\w+(?:-\w+)*\1(*SKIP)(*FAIL)|index=("?)(?<my_indexes>\w+(?:-\w+)*)\2/m';
$str = 'tag=os index=linux index=windows NOT index=mac tag=db index="a_something-else" NOT index=solaris
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);