import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^#].*)?^\\s*dev1";
final String string = "#| Environment | Port-prefix | Subnet | Target-host |\n"
+ "#dev1 300 8 ibdock2\n"
+ "# dev1 300 8 ibdock2\n"
+ " #dev1 300 8 ibdock2\n"
+ " # dev1 300 8 ibdock2\n"
+ "dev1 300 8 ibdock2\n"
+ " dev1 300 8 ibdock2\n"
+ "dev 301 1 ibdock2\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}