# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([(-.+]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+)"
test_str = ("Lorem ipsum foo@bar.com dolor sit amet, 555 123555 consectetur adipiscing elit.\n"
"Here (works) 0606060606 (not works) 06.06.06.0.06.06 06.06 ... .06.06.06 price is 20. 000.000\n\n"
"555.123.4565\n"
"+1-(800)-545-2468\n"
"+ 1 -(800)-545-2468\n"
"2-(800)-545-2468\n"
"3-800-545-2468\n"
"555-123-3456\n"
"555 222 3342\n"
"(234) 234 2442\n"
"(243)-234-2342\n"
"1234567890\n"
"123.456.7890\n"
"123.4567\n"
"123-4567\n"
"1234567900\n"
"12345678900\n"
"+8.4.0.9.6.6.4.3.0.0.9\n\n"
"my price is only 20$, 2000$")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.