import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http|https):\\/\\/)?([a-zA-Z0-9_][-_a-zA-Z0-9]{0,62}\\.)+([a-zA-Z0-9]{1,10})$";
final String string = "xor\n"
+ "xor.com\n"
+ "ww2.xor.co\n"
+ "www.xor.com\n"
+ "val-id.com\n"
+ "-invalid.com\n"
+ "http://xor.com\n"
+ "https://xour.cu\n"
+ "www.http://r.com\n"
+ "https://ww2.xour.cu\n"
+ "s2._domainkey.lixtil.com.au\n"
+ "3426127.group27-.hsbspot.co\n"
+ "hs2._domainkey.lixtil.com.au\n"
+ "3426127.grou p27-.hu3spot.co\n"
+ "little_com_au.xor.tinzy.330.net\n"
+ "3426127.group27.sites.hubseot.net\n"
+ "littil-com-au.hs01a.dkim.hubspoteeail.net\n"
+ "sg2.v8143875.c308460036.e.marketingfutomation.services";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}