// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((http|https):\/\/)?([a-zA-Z0-9_][-_a-zA-Z0-9]{0,62}\.)+([a-zA-Z0-9]{1,10})$").unwrap();
let string = "xor
xor.com
ww2.xor.co
www.xor.com
val-id.com
-invalid.com
http://xor.com
https://xour.cu
www.http://r.com
https://ww2.xour.cu
s2._domainkey.lixtil.com.au
3426127.group27-.hsbspot.co
hs2._domainkey.lixtil.com.au
3426127.grou p27-.hu3spot.co
little_com_au.xor.tinzy.330.net
3426127.group27.sites.hubseot.net
littil-com-au.hs01a.dkim.hubspoteeail.net
sg2.v8143875.c308460036.e.marketingfutomation.services";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}