const regex = /^((https?):\/\/)?([a-zA-Z0-9_][-_a-zA-Z0-9]{0,62}\.)+([a-zA-Z0-9]{1,20})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((https?):\\\/\\\/)?([a-zA-Z0-9_][-_a-zA-Z0-9]{0,62}\\.)+([a-zA-Z0-9]{1,20})$', 'gm')
const str = `xor
xor.com
ww2.xor.co
www.xor.com
val-id.com
-invalid.com
http://xor.com
https://xour.cu
www.http://r.com
https://ww2.xour.cu
s2._domainkey.lixtil.com.au
3426127.group27-.hsbspot.co
hs2._domainkey.lixtil.com.au
3426127.grou p27-.hu3spot.co
little_com_au.xor.tinzy.330.net
3426127.group27.sites.hubseot.net
littil-com-au.hs01a.dkim.hubspoteeail.net
sg2.v8143875.c308460036.e.marketingfutomation.services`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}