re = /^\d+(?:\.\d+)?(?:\s*-\s*\d+(?:\.\d+)?)?$/m
str = '1 - 3
1.35 - 78.55
34
567.78'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end