// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:\.\d+)?(?:\s*-\s*\d+(?:\.\d+)?)?$").unwrap();
let string = "1 - 3
1.35 - 78.55
34
567.78";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}