$re = '/(^|,)IS(,|$)/m';
$str = 'Consider these lines as invidual rows IN THE DATABASE:
IS
IS,TS
WS,CT,IS
TS-IS
WS,CT,IS,TS,TS-IS,TS-WS,TS-CT
WS,CT,NOT JUST IS,TS,TS-IS,TS-WS,TS-CT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);